µLibertad

24/10/2007

Drivers AMD/ATI por fin con soporte AIGLX

Filed under: ATI,Drivers,Linux — Tony @ 6:41 am

La versión 8.42.3 de los drivers fglrx ha sido lanzada. En esta versión por fin tendremos soporte para AIGLX en las gráficas ATI. Esta versión soporta también X.Org 7.3 y X server 1.4 e incorpora mejoras en la reproducción de vídeo, así como también la típica corrección de bugs.

La mala noticia es que no es compatible con la versión 2.6.23 del kernel de Linux, cosa que parece que se solucionará, o por lo menos se espera, en la próxima versión 8.43.

Esta versión recién liberada ha sido probada en todas las gráficas ATI de la serie R300 a la R600.

Se pueden descargar los drivers desde este link.

Fuente | Phoronix

Anuncios

23/09/2007

Los drivers nVidia compatibles con Xorg 7.3 ya están disponibles en los repositorios de Debian Sid

Filed under: Debian,Drivers,Linux,nVidia — Tony @ 5:06 pm

Si utilizas Debian Sid (unstable) estos días seguramente tendrías retenidos los paquetes de Xorg 7.3 por incompatibilidad con los drivers nVidia. Pues bien, desde hoy ya se cuenta con los drivers nVidia compatibles para esta versión de Xorg en los repositorios. Así que ya podéis actualizar las X sin peligro a quedaros sin aceleración 3D. Para poder actualizar primero hay que recompilar el módulo nVidia para tenerlo en la última versión. Es bastante sencillo pero por si acaso alguien no sabe muy bien como hacerlo aquí están los pasos que hay que seguir:

(more…)

22/09/2007

RadeonHD, driver OpenSource para ATI de Novell

Filed under: ATI,Drivers,Linux — opintos @ 4:53 pm

Parece que no paran las noticias respecto a ATI en Linux, que tras liberar la información de sus chipset R600, ve como ahora Novell libera un driver totalmente OpenSource para la serie Radeon 2000 para Linux. Por ahora, solo tiene soporte para 2D, y más bien es una versión para desarrolladores, pero prometen que según vaya AMD liberando información de sus gráficas, irán desarrollando mejores versiones. Por si a alguien le intriga, esta versión tampoco tiene soporte para Composite y AIGLX, todavía, osea que no hay Compiz sin meter una sesión XGL.

Así que ahora tenemos tres frentes en el terreno de los drivers de ATI para Linux, por un lado los Catalyst oficiales de AMD, cuya última versión es la 8.41.7, los RadeonHD de Novell y los de la comunidad que por ahora solo están basados en ingeniería inversa, pero con las especificaciones liberadas recientemente seguro que comienzan a mejora.

En Phoronix han escrito un artículo de como preparar Ubuntu para instalar estos Drivers, pero no es muy recomendable por ahora.

Parece que el tema de los drivers de ATI se anima, pero esperamos ver pronto características más interesantes como el más que necesario soporte para AIGLX y Composite, y por supuesto que den soporte a las gráficas de generaciones anteriores como mi X700 Mobility.

20/09/2007

Primeros progresos con la liberación de las especificaciones de AMD/ATI

Filed under: ATI,Drivers,Linux — opintos @ 11:15 am

AMD tras liberar las especificaciones de las gráficas con chipsets RV630/M56, ha visto como ya han aparecido las primeras mejoras realizadas por parte de la comunidad, que ha recibido con los brazos abiertos las más de 900 hojas de documentación liberadas.

Las mejoras están enfocadas  a la capacidad AVIVO de algunas tarjetas de ATI, que Matthew Garrett ha logrado gracias a encargarse de los registros AVIVO_VGA_MYSTERY, tras poder ver sus verdaderos nombres y valores en la documentación liberada.

Esta documentación esta generando grandes noticias, como por ejemplo que Novell piensa liberar unos drivers de ATI OpenSource para la próxima semana, esperemos que tengan soporte para la versión 7.3 X.org que ya ha sido liberada y los usuarios de ATI aún no tenemos drivers que lo soporten.

Nuevos drivers de NVIDIA para Linux

Filed under: Drivers,Linux,nVidia — opintos @ 10:56 am

Tras la salida de la versión 7.3 del X.org, los drivers de las gráficas Nvidia no eran compatibles y no era posible instalar la nueva versión del X.org manteniendo aceleración gráfica 3D para usar Compiz. Aunque lo mismo pasa con ATI e Intel, pero la noticia es que Nvidia después de tres meses libera una nueva versión de sus drivers para Linux, concretamente la versión 100.14.19.

Las mejoras incluyen soporte para las gráficas Quadro FX 290, 370, 570 y 1700, mejora en el rendimiento de Compiz Fussion gracias a la mejora de “GLX_EXT_texture_from_pixmap out-of-memory handling” que provocaba algunas pantallas negras, varias correcciones de bugs con las GeForce 8800 y mejoras de gestión de energía en todas sus tarjetas y además añaden soporte para la versión 2.6.23 del kernel de Linux. Pero sin duda la mejora más importante es dar soporte al X.org 7.3 que comentaba antes.

Ahora ya será posible instalar las nuevas versiones del paquete xserver-xorg que en la versión unstable de Debian se mantiene retenido desde hace unos días, debido a la ausencia de unos drivers gráficos que lo soporten.

14/09/2007

AMD empieza a mostrar datos de sus GPUs para Linux

Filed under: ATI,Drivers,Linux,Software Libre — opintos @ 1:33 am

Leyendo Noticias3D vemos que ATI/AMD comienza a mostrar las especificaciones de sus tarjetas gráficas, tal y como prometió hace unos días. Estas especificaciones se pueden consultar directamente en Internet en http://www.x.org/docs/AMD/ y constituyen 900 páginas de información sobre el chip RV630 (HD 2600) y el desconocido M56. En la misma noticia se habla de que la próxima semana ATI/AMD lanzará sus drivers open source para sus tarjetas basadas en los R500 y R600, se ve que por ahora, los R400 y R300 se quedan a un lado, y de nuevo no han hablado nada del soporte para AIGLX, que ahora mismo es lo más importante para mucha gente, además de la espectacular mejora de rendimiento claro.

12/09/2007

Ya disponible el driver 8.41.7 para gráficas ATI

Filed under: ATI,Drivers — Tony @ 7:24 pm

Pues como nos prometieron hace poco, AMD ya ha publicado el driver 8.41.7 para las gráficas ATI. Podemos ver más detalles de ésta versión aquí.

Para los que estéis deseando probarlos, desde este enlace os podéis descargar el driver.

Como comentan en las notas, no es recomendable instalarlo en las gráficas ATI Mobility e integradas, siendo la versión 8.40.4 el driver recomendado:

The AMD Proprietary Linux driver version 8.41.7 is not recommended for the ATI Mobility and Integrated Products. Using this driver on any of the following products may result in stability issues. AMD recommends using the AMD Proprietary Linux software driver version 8.40.4.

Una pena para los poseedores de estos productos, habrá que esperar un poco más.

6/09/2007

Más datos sobre los nuevos Drivers ATI

Filed under: ATI,Drivers,Linux — Tony @ 8:40 pm

Como vemos en Entre Tuxes y Pepinos, tras el anuncio de ayer sobre los nuevos Drivers ATI podemos ver un par de datos interesantes:

  • Se desarrollará un Driver 2D y 3D totalmente funcional cuyo soporte se extienda a todos los chipset Radeon más nuevos. Para ello se hará con la colaboración de la comunidad de código abierto y habrá una participación directa de desarrolladores de compañías como Red Hat y Novell.

  • Se publicará la documentación necesaria para que cualquiera pueda desarrollar sus propios Drivers para sus gráficas.

La publicación de las especificaciones 3D es la mejor noticia que nos podrían dar, con ello se podría llegar a tener unos buenos Drivers 3D ya que se ahorraría mucho esfuerzo en ingeniería inversa.

Ahora habrá que esperar qué movimiento hace nVidia al respecto, ya que pueden perder esa posición de ser la primera opción al comprar una gráfica.

5/09/2007

Se avecinan mejores drivers para gráficas ATI en Linux

Filed under: ATI,Drivers,Linux,Tecnología — Tony @ 10:47 pm

Desde Linux Juegos podemos ver como AMD ha publicado una nota de prensa en la que informan sobre las mejoras que introducirán en los drivers de la serie 8.41.X para gráficas ATI. Al parecer estos drivers estarán disponibles a lo largo del mes de Septiembre.

En esta versión prometen soporte completo para AIGLX, así como una mejora de rendimiento que podría llegar hasta el 90% en determinadas configuraciones.

Ya comentamos hace poco la problemática con los drivers de tarjetas gráficas, con esta noticia quizá veamos ahora una mayor competencia en el terreno de las tarjetas gráficas en Linux (que ahora mismo es para nVidia) y repercuta en un mayor beneficio para los usuarios.

24/07/2007

Recompilar el módulo nVidia tras actualizar el Kernel

Filed under: Aplicaciones,Debian,Drivers,Linux,nVidia,Tutoriales — Tony @ 6:06 pm

Esta mañana he recordado algo importante sobre el módulo de nVidia tras actualizar mi kernel del 2.6.21-2-amd64 al 2.6.22-1-amd64. El tema es que si actualizáis el kernel y al reiniciar entráis con él, no podréis iniciar el entorno gráfico dado que el módulo estará compilado para el kernel anterior.

Podemos hacer 2 cosas, recompilar el módulo antes de reiniciar, o entrar con el nuevo kernel y compilar el módulo desde consola. Yo suelo reiniciar y compilar el módulo desde el login por consola, pero explicaré los dos métodos. En ambos casos la solución pasa por utilizar module-assistant.

(more…)

Página siguiente »

Blog de WordPress.com.