µLibertad

27/12/2007

Instalar KDE4 en Debian

Filed under: Debian,KDE4,Linux,Tutoriales — Tony @ 12:59 pm

Para todos aquellos impacientes que no puedan esperar a la salida de la versión final de KDE4, quieran comprobar el estado actual de desarrollo o, simplemente, les apetece chafardear un poco de KDE4, vamos a ver en esta entrada cómo instalaro en Debian.

Antes de nada debéis saber que lo mejor es hacerlo en una instalación aparte de la vuestra habitual, ya que no es compatible con KDE3.5 y os puede dar más de un problema de dependencias y podéis acabar con un sistema lleno de paquetes rotos.

Yo lo he hecho sobre una Debian Stable que tenía en otra partición. Es necesario actualizar el sistema a Inestable y después utilizar el repositorio experimental para instalar los paquetes de KDE4, así que vamos a ver un poco cómo hacerlo.

Lo primero que debemos hacer es añadir a nuestros repositorios la rama experimental para tener disponibles los paquetes de KDE4 actuales, que son los que pertenecen a la RC2 (versión 3.97). Abrimos un terminal y, como root, añadimos estas lineas al sources.list

nano /etc/apt/sources.list

deb http://ftp.debian.org/debian/ experimental main contrib non-free

Ahora actualizamos nuestros repositorios e instalamos kde de la rama experimental:

aptitude update

aptitude install -t experimental kdebase kdebase-bin kdebase-data kdebase-kio-plugins dolphin kappfinder kdebase-bin kdepasswd kfind konqueror konqueror-nsplugins konsole kwrite libkonq5 kwin kdemultimedia kdemultimedia-kio-plugins libkcddb4 juk kmix kscd kdegraphics kolourpaint4 ksnapshot gwenview kdegraphics-strigi-plugins kdenetwork knewsticker kopete kppp krdc krfb kdeutils ark kcalc kcharselect kdf kfloppy kgpg khexedit kjots kmilo kregexpeditor ktimer kwalletmanager kwikdisk superkaramba sweeper kgeography kgeography-data kdeadmin kcron knetworkconf kpackage kuser kde-l10n-es kdegames bovo katomic kbattleship kblackbox kbounce kgoldrunner kiriki kjumpingcube klines kmahjongg kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ksudoku ksquares ktuberling lskat

Son bastantes paquetes, así que paciencia mientras se descarga y se instala.

Es posible que tengáis algunos problemas de dependencias, por eso recomendaba realizar la instalación sobre un sistema no habitual, así podréis eliminar los paquetes que os molesten sin preocuparos demasiado. Así que cuanto más limpia esté la instalación mejor. Mi consejo es que hagáis una instalación con el CD netinst de Debian en otra partición para poder probar tranquilamente KDE4, podéis encontrar un tutorial sobre como hacerlo aquí.

Ahora os dejo unas cuantas capturas de mi KDE4 para que vayáis abriendo boca:

Aquí podéis ver el nuevo Kopete junto con el Widget de Kget (sin Kget cargado) y también el gestor de Widgets:

Aquí está Kget cargado, con su ventana principal. El icono que se ve se puede utilizar para arrastrar url’s dentro de él, así Kget se encarga de descargar dicha url automáticamente:

Este es el Widget para los dispositivos conectados (aparece pinchando en el icono con forma de PC de la bandeja), como veis a mi me ha detectado sin problemas mi Mp3:

Aquí se puede ver uno de los nuevos efectos de Kwin, cuando se abre una ventana que pertenece a otra (como en este caso las preferencias de Dolphin), la ventana de la que procede se oscurece. Es un detalle sencillo pero que hace la navegación más agradable:

Y por último una pequeña muestra de los Widgets para los canales RSS y el paginador de escritorio:

Y por último una captura del nuevo Konqueror:

Pues nada, espero que si os decidís a probar KDE4 antes de su salida esta entrada os sea de ayuda. A ver si alguien se anima y comenta lo que le ha parecido el nuevo KDE  😉

Anuncios

11 comentarios »

  1. Gracias por las explicaciones amigo, espero q gnome se mande algun bellesismo, porq los debianeros lo tenemos por defecto.
    ¡VIVA EL SOFTWARE LIBRE CUANTA CALIDAD Y EXQUISITEZ!

    Comentario por Patowalker Argentina — 28/12/2007 @ 2:54 pm | Responder

  2. Bueno, seguí tus instrucciones, pero al intentar instalar, me saltaron algunos problemas de dependencias, con el paquete kdebase-runtime-data y kdebase-runtime-data-common, ya que la versión que estaba en el mirror tenía una extensión ~svn… no se cuanto, que provocaba los problemas para poder instalar kdebase-runtime-bin.
    Tuve que hacer algo medio sucio, que fue descargar los dos paquetes con versión rara desde otro mirror (http://ftp.gva.es/mirror/debian/pool/main/k/kdebase-runtime/) que tenía la versión anterior, e instalarlos manualmente con dpkg, y después pude instalar todo el sistema kde 4. Ahora está bajando todo, después comento que me pareció!
    Saludos!

    Comentario por Braulio Ríos Uruguay — 29/12/2007 @ 7:46 pm | Responder

  3. Feliz año !!

    Comentario por forat — 1/01/2008 @ 3:45 pm | Responder

  4. muy buen material, muchas gracias!

    Comentario por martin — 7/01/2008 @ 1:06 pm | Responder

  5. Yo creo que para probarlo es mejor bajarse la liveCD, por lo menos hasta que salga de fase beta. En estos momentos estoy bajando la distro de aquí:
    http://pkg-kde.alioth.debian.org/kde4livecd.html
    También hay por ahí una distro similar (pero basada en SuSE), la del enlace es una Debian LiveCD.
    Salu2

    Comentario por DaniFP — 8/01/2008 @ 4:04 pm | Responder

  6. Es que hasta que salga KDE4.1 que será la versión en la que verdaderamente se considere KDE4, no es recomendable instalarlo en un PC de uso diario. Esta entrada está pensada, como bien explica Tony, en realizarla como una prueba para ir viendo que será KDE4, por no usar un LiveCD que puede ser muy lento.

    Comentario por Oscar — 9/01/2008 @ 6:28 pm | Responder

  7. […] per internet, volia provar jo mateix el KDE4 i ahir a la nit el vaig instal·lar seguint les instruccions de µLibertad. He de dir que el sistema base que vaig instal·lar per fer la prova no tenia servidor X i quan […]

    Pingback por Primer contacte amb el KDE4 « llengot:~# — 15/02/2008 @ 5:21 pm | Responder

  8. […] revisar en la web y ver que se podía instalar en mi debian lenny me puse en marcha y me guié por: Libertad y Debian KDE team , los cuales al parecer tenian la informacion requerida para la completa […]

    Pingback por [FireBird] » Archivo del weblog » KDE4 en mi Debian — 23/07/2008 @ 5:49 am | Responder

  9. Bueno, pues KDE4.1 acaba de ser publicado; más info en la página de KDE-Hispano: http://www.kde.org/announcements/4.1/index-es.php

    Comentario por DaniFP — 29/07/2008 @ 8:25 pm | Responder

  10. aptitude install -t experimental kdebase kdebase-b
    in kdebase-data kdebase-kio-plugins dolphin kappfinder kdebase-bin kdepasswd kfi
    nd konqueror konqueror-nsplugins konsole kwrite libkonq5 kwin kdemultimedia kdem
    ultimedia-kio-plugins libkcddb4 juk kmix kscd kdegraphics kolourpaint4 ksnapshot
    gwenview kdegraphics-strigi-plugins kdenetwork knewsticker kopete kppp krdc krf
    b kdeutils ark kcalc kcharselect kdf kfloppy kgpg khexedit kjots kmilo kregexped
    itor ktimer kwalletmanager kwikdisk superkaramba sweeper kgeography kgeography-d
    ata kdeadmin kcron knetworkconf kpackage kuser kde-l10n-es kdegames bovo katomic
    kbattleship kblackbox kbounce kgoldrunner kiriki kjumpingcube klines kmahjongg
    kmines knetwalk kolf konquest kpat kreversi ksame kshisen kspaceduel ksudoku ksq
    uares ktuberling lskat
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Leyendo la información de estado extendido
    Inicializando el estado de los paquetes… Hecho
    No se puede encontrar ningún paquete cuyo nombre o descripción coincida con “kwi
    kdisk”
    No se puede encontrar ningún paquete cuyo nombre o descripción coincida con “kwi
    kdisk”
    Los siguientes paquetes están ROTOS:
    bovo dolphin kdebase kdegraphics-strigi-plugins kiriki kolourpaint4
    ksquares kwrite libkcddb4 libkdegames4 libkonq5 sweeper
    Se instalarán los siguiente paquetes NUEVOS:
    atlantik{a} exiv2{a} gnuift{a} gnuift-perl{a} gwenview imagemagick{a}
    imlib-base{a} imlib11{a} kasteroids{a} katomic kbackgammon{a} kbattleship
    kblackbox kbounce kcoloredit{a} kde-l10n-es kdeedu-data{a} kdegames
    kdegames-card-data{a} kdegraphics kdegraphics-kfile-plugins{a}
    kdelibs-bin{a} kdelibs5{a} kdelibs5-data{a} kdvi{a} kenolaba{a} kfax{a}
    kfaxview{a} kfouleggs{a} kgamma{a} kgeography kgeography-data
    kghostview{a} kgoldrunner kiconedit{a} kipi-plugins{a} kjumpingcube
    klickety{a} klines kmahjongg kmines kmrml{a} knetwalk kolf kolourpaint{a}
    konquest kooka{a} kpat kpoker{a} kpovmodeler{a} kreversi kruler{a} ksame
    kshisen ksirtet{a} ksmiletris{a} ksnake{a} ksnapshot ksokoban{a}
    kspaceduel ksudoku ksvg{a} ktron{a} ktuberling kuickshow{a} kview{a}
    kviewshell{a} kwin4{a} libclucene0ldbl{a} libdate-manip-perl{a}
    libexiv2-4{a} libgnuift0c2a{a} libkdcraw3{a} libkdegames1{a}
    libkexiv2-3{a} libkipi0{a} libkscan1{a} libmrml1c2a{a}
    libparse-yapp-perl{a} libphonon4{a} libpoppler-qt2{a} libqimageblitz4{a}
    libqt4-opengl{a} libraptor1{a} librasqal0{a} librdf0{a} libsoprano4{a}
    libstreamanalyzer0{a} libstreams0{a} libtiff-tools{a} libxml-dom-perl{a}
    libxml-handler-trees-perl{a} libxml-libxml-common-perl{a}
    libxml-libxml-perl{a} libxml-perl{a} libxml-regexp-perl{a}
    libxml-writer-perl{a} libxml-xql-perl{a} libxml2-utils{a} lskat ocrad{a}
    phonon{a} phonon-backend-gstreamer{a} raptor-utils{a} redland-utils{a}
    Se ELIMINARÁN los siguientes paquetes:
    kate{a} kde-i18n-es{a}
    0 paquetes actualizados, 116 nuevos instalados, 2 para eliminar y 0 sin actualiz
    ar.
    Necesito descargar 69,2MB de ficheros. Después de desempaquetar se usarán 132MB.
    No se satisfacen las dependencias de los siguientes paquetes:
    kolourpaint4: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    Depende: libqt4-dbus (>= 4.4.3) pero está instalado 4.4.0-4.
    Depende: libqt4-qt3support (>= 4.4.3) pero está instalado 4.4.0-
    4.
    Depende: libqtcore4 (>= 4.4.3) pero está instalado 4.4.0-4.
    Depende: libqtgui4 (>= 4.4.3) pero está instalado 4.4.0-4.
    kdebase: Depende: kate (>= 4:3.5.9.dfsg.1-5) pero no es instalable
    kiriki: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    libkdegames4: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    ksquares: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    libkcddb4: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    Depende: libqt4-dbus (>= 4.4.3) pero está instalado 4.4.0-4.
    Depende: libqt4-network (>= 4.4.3) pero está instalado 4.4.0-4.
    Depende: libqt4-qt3support (>= 4.4.3) pero está instalado 4.4.0-4.
    Depende: libqtcore4 (>= 4.4.3) pero está instalado 4.4.0-4.
    Depende: libqtgui4 (>= 4.4.3) pero está instalado 4.4.0-4.
    dolphin: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    kwrite: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    sweeper: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    bovo: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    libkonq5: Depende: kdebase-runtime (>= 4:4.1.2) pero no es instalable
    Depende: kdelibs5 (>= 4:4.1.2) pero se va a instalar 4:4.1.0-3.
    kdegraphics-strigi-plugins: Depende: libqtcore4 (>= 4.4.3) pero está instalado
    4.4.0-4.
    Depende: libqtgui4 (>= 4.4.3) pero está instalado
    4.4.0-4.
    Las acciones siguientes resolverán estas dependencias

    Eliminar los paquetes siguientes:
    kde-core
    kdebase
    kdebase-bin-kde3

    Instalar los paquetes siguientes:
    kde-icons-oxygen [4:4.1.2-1 (experimental)]
    kdebase-runtime [4:4.1.2-1 (experimental)]
    kdebase-runtime-bin-kde4 [4:4.1.2-1 (experimental)]
    kdebase-runtime-data [4:4.1.2-1 (experimental)]
    kdelibs-bin [4:4.1.2-2 (experimental)]
    kdelibs5 [4:4.1.2-2 (experimental)]
    kdelibs5-data [4:4.1.2-2 (experimental)]
    libqt4-opengl [4.4.3-1 (unstable, unstable)]
    libstrigiqtdbusclient0 [0.5.11-1 (unstable, testing, unstable)]

    Actualizar los paquetes siguientes:
    libqt4-assistant [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-dbus [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-designer [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-help [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-network [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-qt3support [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-script [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-sql [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-sql-mysql [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-svg [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-test [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-webkit [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-xml [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqt4-xmlpatterns [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqtcore4 [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    libqtgui4 [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]
    qt4-qtconfig [4.4.0-4 (testing, now) -> 4.4.3-1 (unstable, unstable)]

    La puntuación es -1218

    ¿Acepta esta solución? [Y/n/q/?]

    Tendre algun tipo de problema si acepto?

    Desde ya muchas gracias

    Comentario por jigcau89 — 16/10/2008 @ 12:21 pm | Responder

  11. Despues de muchos comentarios en bastantes sitios… me he decidido a instalar kde 4.2 espero no decepcionarme

    Saludos.
    Pd: en este momento apt-get install ….

    Comentario por KernelK — 31/01/2009 @ 12:22 am | Responder


RSS feed for comments on this post. TrackBack URI

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Crea un blog o un sitio web gratuitos con WordPress.com.

A %d blogueros les gusta esto: